2009年02月19日

ドリトルについて(その6)「続・かめた!千鳥足」

ドリトルについて(その5)「かめた!千鳥足」の続きです。
ドリトルの記事全体はカテゴリ「ドリトル」をご覧下さい。

さて前回のタイトルに冗談のように「かめた!千鳥足」と書きましたが、このように新しい命令を作って実行させることはできないのでしょうか。

実はできます。

オブジェクト:新命令の名前=「 」。


という記述で、このオブジェクトに新しい命令を追加することができます。さっそくかめたに「千鳥足」を追加してみましょう。前回の内容をすべて「 」に入れればいいのですね。

例1)
かめた=タートル!作る。

かめた:千鳥足=「
かめた!(乱数(360))左回り。
時計=タイマー!作る。
時計!「かめた!(乱数(60)−30)左回り 5 歩く」 実行。
」。


これを実行すると、真ん中にかめたが登場して終わります。どうしてでしょう?
ドリトル新規命令で動かない

続きを読む
posted by n_shimizu at 22:54| Comment(0) | TrackBack(3) | ドリトル