2009年02月08日

ドリトルについて(その1)

ドリトルが情報科仲間で流行りました。自分でもやってみてこれは面白いと思い12月の授業で実践しました。なかなか好評だったようです。

このブログで書くとネタバレになってしまうことになるので今まで書きませんでした。全クラスで一通り1時間はやったので書くことにします。

ドリトルとは学習用プログラミング言語の一種です。

JAVA上で動くので、JAVA 環境さえあれば基本的にどんなマシンでも動きます。オンライン版もあるのでブラウザ上で動かすこともできます。

特徴としては、学習用とはいってもオブジェクト指向言語であること。基本はタートルグラフィックスなので、結果がすぐに見えること(もちろんグラフィックを使わないプログラムも作れます)。日本語(日本文字?)を使っているのでイメージを掴みやすいこと。でしょうか。

こんな感じです。
かめた=タートル!作る。
かめた!100 歩く。


実行結果は次のようになります。
ドリトル実行画面


可愛いカメのキャラクターが100歩(100ドット)分だけX軸方向に進み、軌跡を残します。

もう少し言うと、タートルというのは「プロトタイプオブジェクト」というものです。JAVA などの class のようなものです。タートルグラフィックスの主体となるオブジェクトで、通常は移動させることで軌跡を描くことができます。タートルグラフィックスとは、亀の尻尾が筆になっていて、亀を歩ませると尻尾で絵が描けるイメージのプログラミングを言います。

「タートル」はプロトタイプなので「作る」でコピーを作りこれに「かめた」という名前を付けるのが1行目です。名前を付けないと一度は実行できても、同じものに続けて命令することはできなくなってしまいます。

基本的な文法は、
オブジェクト!命令。

です。オブジェクトにメッセージを送るのには「!」で区切ります(半角でも大丈夫です)。各オブジェクトにはそれぞれ指定できる命令が決まっていて、タートルオブジェクトに対しては、
作る、歩く、戻る、右回り、左回り、移動する、位置、向き、ペンなし、ペンあり、閉じる、変身する、拡大する、線の色、線の太さ、衝突

等があります。またオブジェクトの種類はグラフィックオブジェクト(タートル、図形、パレット)の他、

基本オブジェクト(数値、文字列、ブロック、タイマー等)
GUIオブジェクト(ボタン、フィールド、ラベル等)
音楽オブジェクト(メロディ、コード、ドラム、楽器)

などがあります。

2行目は、名前を付けた「かめた」に対して命令します。かめたはタートルのコピーなので、タートルオブジェクトと同じ命令を実行できます。日本語を意識しているので、通常の言語では、
命令 パラメータ

の順番ですが、ドリトルの場合は、
パラメータ 命令

の順番になります。なので「100 歩く」です。パラメータと命令の間にはスペースが必要です。この「100」や間のスペースは半角でも全角でも区別しません。基本的に全角半角は区別しません(ファイル名などの場合は大文字小文字まで含めて正確に記述する必要があるようです)。

最後の「。」は命令の区切り記号です。C言語やPHPなどの「;」と同じです。逆に言うと、1行に複数の命令を並べても実行されます。従って、
かめた=タートル!作る。かめた!100 歩く。

でも同じ動作をします。通常は見やすさのために1行1命令で記述します。
当然、無い機能は命令できません。
歩け、進む、右周り、跳ねる、など

日本語を使っているので、ついついやってしまいがちですが、無いものは無いとエラーが出ます。上記のものはどこがまちがっているか分かりますか?

疲れてきたので今日はこの辺にしておきます。

一番良い参考書は作者の書いた次の本がお薦めです。

posted by n_shimizu at 22:55| Comment(0) | TrackBack(4) | ドリトル
この記事へのコメント
コメントを書く
お名前: [必須入力]

メールアドレス:

ホームページアドレス:

コメント: [必須入力]

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。
この記事へのトラックバックURL
http://blog.sakura.ne.jp/tb/26464194
※言及リンクのないトラックバックは受信されません。

この記事へのトラックバック

ドリトルについて(その2)
Excerpt: 前回(ドリトルについて(その1))の続きです。 タートルオブジェクトについてもう少し詳しく言うと、 タートルオブジェクトとは *グラフィック関係のオブジェクトの一つ *移動する時に軌跡の線を残し、..
Weblog: 情報科雑感
Tracked: 2009-02-10 02:02

ドリトルについて(その3)
Excerpt: ドリトルについて(その1) ドリトルについて(その2) の続きです。 タートルオブジェクトには、「右回り」、「左回り」という命令があります。進行方向を回転させる命令です。 90 右回り と指定す..
Weblog: 情報科雑感
Tracked: 2009-02-10 18:03

ドリトルについて(その4)
Excerpt: ドリトルについて(その1) ドリトルについて(その2) ドリトルについて(その3) の続きです。 ドリトルは、インタープリターですから、作っては試し、作っては試しとできるところが大きな特徴ですから、..
Weblog: 情報科雑感
Tracked: 2009-02-14 00:12

ドリトルについて(その5)「かめた!千鳥足」
Excerpt: ドリトルについて(その1) ドリトルについて(その2) ドリトルについて(その3) ドリトルについて(その4) の続きです。 そろそろかめた自身に勝手に歩かせてみたいと思います。 ドリトルには「乱..
Weblog: 情報科雑感
Tracked: 2009-02-15 14:57