2009年02月10日

ドリトルについて(その2)

前回(ドリトルについて(その1))の続きです。

タートルオブジェクトについてもう少し詳しく言うと、

タートルオブジェクトとは
*グラフィック関係のオブジェクトの一つ
*移動する時に軌跡の線を残し、絵を描くことができる
*描いた絵を切り離して図形にすることができる
*規定値として
 ○「作る」と原点(0,0)に現れる
 ○ペンあり。線の色は黒
 ○「歩く」方向はX軸正の方向
 ○亀の絵

などということが性質や規定値として決まっています。ほとんどが「そうだろう」と思うような自然な規定値になっています。単にイメージを掴むためだけの場合はそのようなことを意識する必要はないけど、ちゃんとプログラミングをしたい場合はそのように「決まっている」ということを知っておく必要があると思います。

特にタートルグラフィックスのオブジェクトだから名前が「タートル」で亀の絵になっているんですけど、ほとんどシャレに近い(だから「変身する」で花を表示させたときになぜ「タートル」から花になるのかといった疑問に繋がる生徒がいます)。

さて、「作る」はコピーで、名前を付けることができることは前回説明しました。次のようなプログラムを実行してみましょう。

かめた=タートル!作る。
かめた!100 歩く。
かめこ=タートル!作る。
かめこ!100 戻る。


実行結果は次の通りです。
かめたとかめこ
「戻る」は単に負の方向に進むための「歩く」のエイリアスということなります。したがって、右が「かめた」、左が「かめこ」ということになります。

このように、二つのオブジェクトを作り、別々に命令することができるようになるわけです。

さらに文法について少し述べます。同じオブジェクトについての命令は並べることができます。

次のようなプログラムがあったとします。

宝=タートル!作る。
宝!“tulip.png” 変身する。
宝!ペンなし。
宝!100 100 位置。


中身についての詳しい説明は省きます。

さて、これは次のように記述することができます。

タートル!作る "tulip.png“ 変身する ペンなし 100 100 位置。


ドリトルは実行した結果もまたオブジェクトになり、それをそのまま右側の命令が実行するということになっています。

今日はこの辺にしておきましょう。
posted by n_shimizu at 02:01| Comment(0) | TrackBack(3) | ドリトル
この記事へのコメント
コメントを書く
お名前: [必須入力]

メールアドレス:

ホームページアドレス:

コメント: [必須入力]

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。
この記事へのトラックバックURL
http://blog.sakura.ne.jp/tb/26549444
※言及リンクのないトラックバックは受信されません。

この記事へのトラックバック

ドリトルについて(その3)
Excerpt: ドリトルについて(その1) ドリトルについて(その2) の続きです。 タートルオブジェクトには、「右回り」、「左回り」という命令があります。進行方向を回転させる命令です。 90 右回り と指定す..
Weblog: 情報科雑感
Tracked: 2009-02-10 18:03

ドリトルについて(その4)
Excerpt: ドリトルについて(その1) ドリトルについて(その2) ドリトルについて(その3) の続きです。 ドリトルは、インタープリターですから、作っては試し、作っては試しとできるところが大きな特徴ですから、..
Weblog: 情報科雑感
Tracked: 2009-02-14 00:13

ドリトルについて(その5)「かめた!千鳥足」
Excerpt: ドリトルについて(その1) ドリトルについて(その2) ドリトルについて(その3) ドリトルについて(その4) の続きです。 そろそろかめた自身に勝手に歩かせてみたいと思います。 ドリトルには「乱..
Weblog: 情報科雑感
Tracked: 2009-02-15 14:57