2009年02月14日

ドリトルについて(その4)

ドリトルについて(その1)
ドリトルについて(その2)
ドリトルについて(その3)
の続きです。

ドリトルは、インタープリターですから、作っては試し、作っては試しとできるところが大きな特徴ですから、前回の回答編はそのようにしてみましょう。

まず、100ドットの正三角形の描き方について。

正三角形の一つの角は60度だから60としていすればいいんだ!
と思った方いると思います。次のように。

例1)
かめた=タートル!作る。
「かめた!100 歩く 60 右回り。」!3 繰り返す。


これを実行してみましょう。
ドリトル正三角形ならず

……三角形になりません。なぜでしょう?
「右回り」という命令は何だったか思い出してください。タートルオブジェクトの進行方向を回転させるものでした。つまり、できた角の角度を指定するものでは無いのです。ここで指定するのは60度の角を描くために曲がる角度、数学的に言えば外角ですから、120度を指定しなければならないのです。

タートルオブジェクトに出す命令は外から見た図からではなく、あくまでも「タートル」になったつもりにならなければなりません。

修正したプログラムはこうです。

例2)
かめた=タートル!作る。
「かめた!100 歩く 120 右回り。」!3 繰り返す。


実行結果はこうなります。
ドリトル正三角形できた

ちゃんと正三角形になりました。

これで課題は解決ですが、頂点が上に来た方が具合がいいですね。最初に X軸正の方向に進み右に曲がると画面上では下に進んでしまうので、最初の線を底辺にするには左に曲がればいいことが分かります。

例3)
かめた=タートル!作る。
「かめた!100 歩く 120 左回り。」!3 繰り返す。


実行結果
ドリトルきれいな正三角形

頂点が上にあるきれいな正三角形になりました。

同様にして、
・正六角形は60度を6回左回り
・正五角形は72度を5回左回り

とすれば良いわけですね。やってみてください。

☆形は、トライ&チャレンジでやってみるのがいいかもしれません。正解は、

例4)
かめた=タートル!作る。
「かめた!100 歩く 144 右回り。」!5 繰り返す。


となります。結果は次の通り。今回は右回りにしてみました。
ドリトルきれいな☆形

今日はこの辺で。
posted by n_shimizu at 00:10| Comment(0) | TrackBack(1) | ドリトル
この記事へのコメント
コメントを書く
お名前: [必須入力]

メールアドレス:

ホームページアドレス:

コメント: [必須入力]

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。
この記事へのトラックバックURL
http://blog.sakura.ne.jp/tb/26703420
※言及リンクのないトラックバックは受信されません。

この記事へのトラックバック

ドリトルについて(その5)「かめた!千鳥足」
Excerpt: ドリトルについて(その1) ドリトルについて(その2) ドリトルについて(その3) ドリトルについて(その4) の続きです。 そろそろかめた自身に勝手に歩かせてみたいと思います。 ドリトルには「乱..
Weblog: 情報科雑感
Tracked: 2009-02-15 14:57